Security Maintenance Extension of Ruby 1.8.7 and 1.9.2.

Heroku - A Patch in Time: Securing Ruby.

Heroku has stepped up to support Ruby 1.8.7 and 1.9.2 for an additional 6 months. It’s good that they are still maintained, but it does reduce the incentives to upgrade. This “reverses” the sunset of 1.8.7, in some sense.

From the post:

This maintenance extension is made possible by Heroku, see their blog post A Patch in Time: Securing Ruby for more information.


You may remember an announcement approximately 6 months ago that sunset 1.8.7.

While ruby-core will no longer resume maintenance of 1.8.7 or 1.9.2, Terence and Zachary will support these versions for security maintenance as part of a corporate sponsorship.